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Abstract:

The following tutorial is a step by step guide to creating a simple 3D model using the SolidWorks solid modeling software.  As a tie in to optical science, the component being modeled is a Watec 902H2 Ultimate compact security camera.  The final model is completed by creating sketches of the cross sectional areas of the camera and then by extruding those sketches.   
SolidWorks in the Design Process:
SolidWorks is an incredibly powerful tool in both mechanical and optomechanical design.  As a solid modeling program, it can be used throughout the design process.  SolidWorks can be used to create rough models to provide the engineer component perspective and a feel for how parts will fit together.  It can also be used as a very detailed design tool where every piece of a design down to the fasteners is included.  The weights of these components can also be specified to create a very accurate representation of what the actual part will look like.  In this particular example, a rough solid model of a compact security camera will be created.  The camera, whose model will be useful for component layout in a larger assembly, can be seen in Figure 1.  It is called a Watec 902H2 Ultimate and is a B&W security camera.
Figure 1:  Watec 902H2 Ultimate
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Document Preparation:
The first, and most obvious step in creating this solid model is to open a licensed version of SolidWorks.  SolidWorks will bring up a blank screen with a panel of toolbars placed along the top.  To start a new SolidWorks file, the user must select File -> New.  This will bring up a screen giving the user the option to open either a Part, an Assembly, or a Drawing.  A Part is the file that is used to model one individual component.  An Assembly is a collection of Parts and is used to assemble numerous models into one larger model.  A Document is used to create a 2D drawing of a 3D solid part.  In this particular case, because we are looking to create just one model of a camera, we will be selecting Part.  
A blank screen will thus appear after selecting a Part file.  The origin of this model can be seen in the center of the blank screen with an X-Y-Z coordinate system shown in the bottom left hand corner of the drawing.  Before we start drawing our part, the units of the document must be established.  To choose a set of units for the document, the user should select Tools -> Options.  This will bring up a System Options panel.  Two tabs can be seen at the top of the panel.  This first is System Options and the second is Document Properties.  Document Properties is to be selected and the Units tab along the left side of the panel is to be selected.  A list of usable unit systems appears and the correct unit system is to be selected.  Because the specification sheet we have for the Watec camera is in units of millimeters, we will select MMGS (millimeter, gram, second).  Select OK and the blank model screen once again appears. Figure 2 shows the toolbars that will be of most importance as this part is created.
Figure 2:  Important Toolbars
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· Blue Circle – number 1:  the Feature/Sketch tab.  These tabs are the gateway to opening their own unique toolbars, which appear to the right of each tab.  On a basic level, the Feature tab is used for adding depth to 3D sketches as well as for adding complexities to those 3D models.  The Sketch tab is used for creating 2D sketches.  Once a sketch is made, it can then be extruded using the options given under the Feature tab.  
· Red Circle – number 2:  the Design Tree.  This panel shows all of the broad details of each model.  What is shown in Figure 2, is a design tree before any sketch is created.  The design tree shows which planes are available, in this case the front, top, and right planes, as  well as the location of the origin.  When sketches and 3D components are created, they will be added to the bottom of the design tree.

· Green Circle – number 3:  the zoom and views toolbox.  This toolbox is useful for adjusting the view of each model.  The buttons on the left side of the toolbox are used for zoom in and out, and the far right dropdown button allows the user to select one of a wide range of offered views.

These toolbars are going to be used most frequently in the basic design process.  With a basic understanding of what each toolbar can be used for, modeling the simple camera can begin.
Creating a Sketch:

There are 2 basic shapes that need to be created before depth can be added.  Each shape will be a representation of the part’s cross section.  As this is a rough drawing, the first cross section will be the body of the camera, which is a square with rounded corners.  The second cross section will be the circle of the lens mounted on the front panel of the camera body.  To begin this model, a sketch of the camera body will be created.  

· Sketching the Camera Body

The planes that are seen in the design tree are very important in drawing sketches in SolidWorks.  All 2D sketches must be drawing within a plane.  For the camera body sketch, the Front Plane is to be selected on the design tree.  A red box depicting the front plane is highlighted once the front plane is selected.  Next, the user should click on the dropdown button on the far right of the zoom and view toolbox.  A list of possible views is shown.  A Front view should be selected.  The screen will then be a front view with the front plane selected.  We are now ready to sketch.  
To begin with, the Sketch tab is to be selected.  This will create a new panel of options to the right of the Sketch tab.  This new panel includes options such as Line, Rectangle, and Circle.  These are all shapes that can be sketched.  Because the camera body cross section is a square, we will be selecting the Rectangle tool.  As soon as a tool is selected, a sketch is added to the design tree.  The label, Sketch1, represents the first sketch of this model.  With the rectangle tool selected, click on the origin, keep the left mouse button depressed, and drag the mouse up and to the right of the origin.  The magnitude of this drag is currently unimportant.  A green box is thus created with some random set of dimensions depending on how far the rectangle was dragged.  Next, the user should once again click on the Rectangle tool to unselect the newly created box, and to bring back the arrow pointer.  There are 4 sides to this cross section.  Two of these sides will appear black in color, while the other 2 will be blue.  The dimension of the blue sides can be manipulated.  Click on the top line of the box and a Line Properties panel will appear to the left of the screen as shown in Figure 3.
Figure 3:  Line Properties
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As can be seen in the left panel under parameters, the length of this line is selected.  By referring to Figure 1, the Watec technical drawing, the correct length of this line is 34 mm.  Thus, 34 should be inserted into the currently selected box.  The both the top and bottom lines will then change to that length.  Similarly, the right blue line can be selected and can also be changed to 34 mm.  There are two buttons in the upper right corner of the drawing panel.  The top button is a pencil with a purple arrow and the bottom is a red X.  The top button will save the changes made to the sketch while the bottom will cancel what was drawn.  In our case, because our box is now dimensioned correctly, the top button is to be selected and the drawing will be saved.  
The overall shape of the camera body cross section is now completed but there is an additional detail that is worth modeling.  A fillet can be added in each corner to create the rounded cornered camera body.  To do this, right click Sketch1 in the design tree and select the first option, Edit Sketch.  This will allow the user to go back and edit what was just saved.  Still in the same Sketch toolbox, the button Sketch Fillet is to be selected.  Immediately, a Sketch Fillet panel appears on the left side of the screen.  The fillet radius can be selected in this panel.  For our model, a radius of 7 mm is to be entered into the Fillet Parameter box.  Next, lines of the rectangle must be selected.  Begin by selecting the top line and the right line.  The result can be seen in Figure 4.  
Figure 4:  Creating a Fillet
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Continuing around the box, the right line and then the bottom line can be selected in the same manner.  That corner will then be rounded at a 7 mm radius.  This can be done to each side until each corner has a 7 mm fillet.  The green check mark in the upper right corner is then to be selected to save the fillets and then the pencil and purple arrow button is to be selected to save the changes to Sketch1.  The cross section of the camera body is now complete.
Creating an Extrusion:
· Adding Depth to Sketch1
To add depth to the camera body cross section, the Features tab is to be selected.  Next, select Sketch1 from the design tree.  You should have noticed the new toolbox that has appeared from selecting the Features tab.  The first button in that toolbox is the Extruded Boss/Base button.  Select this button and an isometric view of the extruded sketch appears.  This can be seen in Figure 5.  

Figure 5:  Extruded Sketch1
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On the Extrude properties panel that appears on the left of the screen, the distance of extrusion can be selected.  By again referring to Figure 1, it can be determined that the depth of the camera body is to be 40 mm.  Enter this in the box that is highlighted in Figure 5 and select the green check mark button in the upper right hand corner.  It should be noted that once this extrusion is saved, a new title is created in the design tree with the name Extrude1.  This represents the camera body 3D model we have created.  By selecting the small plus sign to the left of the Extrude1 title, the dropdown menu shows the sketch, in this case, Sketch1, that was used to create this extrusion.  We have now created our first 3D part.
Creating a Sketch: 

· Sketching the Camera Lens
The sketch for the camera lens is begun in the same way the camera body sketch was.  First select the Front Plane, and then change the view to Front.  The circular cross section of the camera lens can then be created.  Click the Sketch button and select the Circle tool.  In order to perfectly center the circle on the camera body, reference lines can be used.  With the Circle tool selected, hover over the midpoint region of the top line.  Once the midpoint has been found, continue to hover, but move the arrow down towards the center of the camera body.  A dotted reference line should appear.  Hovering over the midpoints will activate these reference lines.  Next, find the midpoint of the right line should be found.  By hovering over this point and moving towards the center of the camera body, a second reference line is created.  When this reference line is dragged to the point where it intersects the first reference line, a vertical reference line will appear and you have found the very center of the camera body.  This can be seen in Figure 6.
Figure 6:  Creating Reference Lines
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Once these two lines are found, now the user can left click.  The center point of a circle has been created at this point.  Continue to hold down the left mouse button and drag the circle out to an arbitrary distance.  A Circle properties panel, which can be seen in Figure 6, can be then be used to change the radius of the selected circle.  Referencing Figure 1, the radius of this circle is found to be about 15.5 mm.  Enter this value in the radius box and hit the purple arrow button in the top right corner of the screen to save the newly dimensioned circle.  A Sketch2 has been created in the design tree and this new sketch is ready for extrusion.
Creating an Extrusion:
· Adding Depth to Sketch2

Again, in the same way we began the extrusion for the Sketch1, the Features button is to be selected.  Next, Sketch2 in the design tree is to be selected and Extruded Boss/Base is chosen.  This will once again show a preview of what the newly extruded component will look like.  This time though, the view will not automatically change to an isometric view.  This must be done manually after this first extrusion.  Thus, by going to the dropdown view button, select the Isometric view and the magnitude of the extrusion can be seen.

It should be immediately noticed that the extrusion is going in the same direction as the camera body.  This is the wrong direction for our camera lens.  By clicking on the small Reverse Direction button to the left of the box with Blind shown within it, the direction of extrusion will be flipped.  This can be seen in Figure 7.

Figure 7:  Flipping the Extrusion Direction
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As can be found from Figure 1, the depth of the lens extrusion should be set to roughly 10 mm.  The green check mark should then be selected and the final extrusion of our rough 3D model is complete.

The Finished Model:
Through a series of sketches and extrusions, a simple model of the Watec 902H2 Ultimate security camera is created.  The completed model is shown in Figure 8.

Figure 8:  The Finished Model
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