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Purpose

•Provide you with an overview of CODE V structure, interface, 

and capabilities for optical system:

Modeling Analysis Optimization

MTF
PSF

Image 

Simulation
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Where do I get CODE V?

New User Orientation
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CODE V Access for Distance Students

• Send email to osg_educ@synopsys.com, indicate you need CODE V for your distance learning 

class, include:

1. Your full contact information (full name, phone number, and university/college address)

2. Answer the following questions:

1. Are you a citizen of Cuba, Iran, North Korea, Sudan, or Syria? If yes, then answer question

2. Are you a permanent documented legal resident or dual citizen in a country other than Cuba, Iran, North 

Korea, Sudan, or Syria?

3. Go to: http://optics.synopsys.com/support/support-host-id.html Download and save the GetHostID.exe program 

to the desktop of your computer that you will use the software. Right-click on the program and select ‘Run as 

Administrator’. An error message will appear “No hardware dongle detected, continue?” select yes. The 

GetHostID dialog box will appear, copy the Hardware Host ID (4-XXXXX) and send it to us via email. 

– Note: Your license will only work on the computer you provide the Hardware Host ID from and it is not possible to 

use the license on another computer. 

• Local students: Contact Ms. Ruth Corcoran (rcorcoran@optics.arizona.edu) in the academic 

office

Please allow 5-10 business days for processing…we receive many requests this time of year

http://optics.synopsys.com/support/support-host-id.html
mailto:rcorcoran@optics.arizona.edu
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Education for CODE V Users

Customer Support Portal, and Training

New User Orientation
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Resources for Learning CODE V

• Various CODE V Help Choices (HELP > … )

• The Customer area of the ORA website: support.opticalres.com

– Introductory & Advanced Training presentations

–CODE V User Group meeting presentations

–CODE V Webinar recordings

–Release notes

–E-news Tips

–Tech Support FAQs

–Macro downloads

–Technical papers

Intro Topics in CODE V Training

Optics 101

Digital Camera

User Interface

Tech Talk

Apertures/Vignetting

Performance Eval.

Optimization

Reflective Systems

Tilts/Decenters

Non-Spherical

Afocal

Zoom

Tolerance Analysis

Macros
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The Synopsys Optics Customer Support Portal contains 

resource to help you learn and stay up to date

• http://support.opticalres.com/

• The material is exclusive to Synopsys 

Optics software users, so requires a 

different log in from SolvNet

• Training Videos

• Training Presentations

• User Group Presentations

• Glass catalog updates

New User Orientation

http://support.opticalres.com/
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Training Courses and User Group Meetings

• Introduction to CODE V:

– September 25-29, 2017, in Pasadena, CA (Los Angeles area)

• Advanced Topics in CODE V:

– October 23-25, 2017, in Mt. View, CA (San Jose area)

• CODE V User Group Meetings, typically held in June 

– Free, 1-day meetings held in Mountain View, CA (San Jose area), Pasadena, CA (Los Angeles area), 

and Rochester, NY 

– Topics from 2017

– CODE V 11.0 New Features and Future Plans

– Tools for Wide Angle Systems

– Tips and Tricks

– Color Correction: Fundamentals and Techniques

– Topics in Interferograms

– Beam Synthesis Propagation with Lens Arrays

New User Orientation



© 2016 Synopsys, Inc. 10 CODE V®

CODE V Help

• CODE V reference manual (PDF) has the most info

e.g. Search on “database items” 

provides links to syntax for various 

database info (curvatures, 

thicknesses, pupil size… any 

CODE V info)
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Robert E Hilbert Student Design Competition

• Be sure to submit your best CODE V 

project to our annual Student Design 

Contest (optics.synopsys.com)
– $4,000 in prizes awarded each year
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Now…let’s get started with CODE V

New User Orientation
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CODE V is a Sequential Ray Tracer*

*There is a non-sequential mode…but we won’t talk about that today

Rays trace from surface 1 -> surface 2 -> surface 3 ->…->until the image

Used for imaging systems
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…compared to a non-sequential ray trace program

Used for illumination systems, stray light, etc.

Images from LightTools®

Backlights

Luminaires

Lamps

Rays start from source(s) ->bounce around geometry -> Measure illumination pattern on receiver(s)
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This presentation covers…

• Refractive system data entry

• Reflective system data entry

• Interacting with analysis options

• Design example: Digital Camera

– Finding a starting system

– Setting up a specifications table

– Optimizing for improved performance

New User Orientation
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Interface Elements

New User Orientation

Title Bar

Navigation 

Toolbar

Menu Bar

Toolbars

LDM 

Spreadsheet

Command 

Window

Command Line

Status Bar

Tabbed 

Output 

Window

Interactive 

3D 

Visualization 

window

Command 

Window
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CODE V Interface (GUI Components)

CODE V® - Digital Camera Design Study

Title Bar

Navigation 

Window

Menu Bar Toolbar(s)

Re-execute & 

Modify Settings

Status Bar
Text Window Splitter
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CODE V Interface (SpecBuilder™)

CODE V® - Digital Camera Design Study

Insert/Edit 

Specification dialog

SpecBuilder 

Window

SpecEvaluator™ 

Button

Evaluation 

Information 

Window
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CODE V Interface (Input)

CODE V® - Digital Camera Design Study

LDM 

Spreadsheet

Command 

Line

Surface 

Properties 

Window

System 

Data

Window

Review 

Spreadsheet(s)
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CODE V Interface (Output)

CODE V® - Digital Camera Design StudyDisplay > 3D Visualization Error Log

Display > 

View Lens

Display > 

List Lens 

Data (text 

window)

Plot 

Window

Tabbed 

Output 

Windows

Command 

Output    

Window
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CODE V Interface (Tabbed Output Window Components):

CODE V® - Digital Camera Design Study

Input 

Dialog

Text Output

Tabbed 

Graphical 

Output



© 2016 Synopsys, Inc. 22 CODE V®

SpecBuilder Features at a Glance

Re-orderable 

rows

Specs for 1st Order & other System Parameters, Mechanical Constraints, Nominal & As-Built 

Performance, Attributes Specific to the CODE V model, and User-Defined specifications

User-Specified 

Notes, with 

double-byte 

character 

support

User-specified “Goal Mode” defines the 

comparison of the current spec value against 

the spec target

User-specified Target & the current, 

or min/max Values. Highlighted 

cells for “Values” out of “spec”

Supporting 

information 

accessible via 

the     i            

icon and 

error/warning 

information 

via the       

icon

Specs can be 

active or 

inactive       

(use      check 

box for “all 

active/all 

inactive”

Select All     

and copy & 

paste the 

table into 

another 

application

User-Specified labels, with double-byte 

character support

CODE V® - Digital Camera Design Study
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Opening a Lens

• New Lens Wizard can open a blank lens, CODE V sample lens, or a patent lens
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Opening a Lens

• Filter list of 2,400 

patent lenses for 

desired criteria
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Data Entry

• 3 main windows for 

entering data

–Lens Data Manager 

(LDM): radius, 

thickness, glass, 

circular apertures, 

and indicators

–System Data

–Surface Properties

LDM
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Data Entry

• Right-click for context sensitive menus

• Some operations (e.g. insert, delete) 

require you to highlight the row first

• Some fields (e.g. Surface Type, 

Refract Mode) you double-click 

for a drop down list
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Data Entry

• Allows copy/paste of cell values or a range of cells

• Allows use of expressions in cells
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Data Entry

• Be sure that the program accepts data that is entered by one of these methods:

–Clicking on a different cell

–Clicking the “Commit Changes…” button

–Hitting the TAB key

–Hitting the ENTER key

Not accepted Accepted
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Demo: Lens Data Entry

Getting to know the Lens Data Manager

New User Orientation
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Data Entry – Ex. Doublet

• Open a blank lens from New Lens Wizard

• From menus open Lens > System Data

• Set pupil size, Entrance 
Pupil Diameter = 33.3

• Use F,d,c wavelengths (can 
use a pre-stored spectrum)

• Define fields as Object 
Angle, 0, 2, and 3 degrees
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Data Entry – Ex. Doublet

• Insert 2 surfaces

(Or press “Insert” button twice) 

Right-click

• Enter data for thicknesses and curvatures

Type BSM24 and SF1 for glass material (automatically searches the catalogs)
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Data Entry – Ex. Doublet

• Add a paraxial image solve 

and do a quick best focus

• Set surface 1 to be the stop

Right-click

Grayed out cell is not directly editable; value is 

computed (by a solve, a pick up, or default 

value). Right click change to an editable quantity.
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Data Entry – Ex. Doublet

• Commands (copy and paste to the command line)

LEN NEW

EPD 33.3

WL 656.2725 587.5618 486.1327

YAN 0 2 3 

INS S1..2

S1 61.0722 10.3456 BSM24

S2 -42.1754 2.3513 SF1

S3 -316.1385 0 

PIM

STO S1

WAV; BES; RFO; GO

Command line
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Analyses

• Display>List Lens Data…

–List surface data, system data, first order data, 
indices, etc.

• Display>View Lens

–2D layout

• Display>3D Viewing

–Open-GL solid model, 
interactive rotation/zoom
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Analyses
• Analysis>Diagnostics>Paraxial Ray Trace

–1st order ray trace

• Analysis>Diagnostics>Third Order Aberrations
–List the surface contributions and sum of the transverse third order aberrations for the system

• Analysis>Diagnostics>Fifth Order Aberrations
–List the surface contributions and sum of the third and fifth order aberrations for the system (and 

elliptical coma)
–Output can be in terms of transverse or wave aberrations
–Output can be in terms of imaging or pupil aberrations
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Analyses

• Analysis>Diagnostics>Ray Aberration Curves or OPD Aberration Curves
–Useful for determining which aberrations are present in the lens

–Quick buttons actually run a macro which does auto-scaling
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Analyses
• Analysis>Geometrical>Spot Diagram

– Plots ray intercepts at the final surface for each field 

• Analysis>Diffraction>MTF

– Modulation Transfer Function values and plots

• Analysis>Diffraction>Wavefront Analysis

– Listing of RMS Wavefront error
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Demo: Entering a Reflective System

New User Orientation
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Data Entry – Ex. Reflective

• Start with a new lens, and enter system and surface info same as the 

previous doublet example

–Entrance Pupil Diameter (EPD) 75

–Wavelengths d,F,c spectrum (656.3, 587.6, 486.1)

–Fields, Object angles 0 5.5 degrees

–Solves, Paraxial image solve

• Insert 4 surfaces, and make surface 1 the stop
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Data Entry – Ex. Reflective

• Note negative thicknesses.  Rays travel in the opposite direction after each 

reflection.  The coordinate system doesn’t change

• Access Asphere coefficients in Surface Properties window

Double-click

Right-click
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Data Entry – Ex. Reflective

• Commands (copy and paste to the 

command line)

LEN NEW

EPD   75.0

WL    656.3 587.6 486.1

YAN   0.0 5.5

PIM

INS S1..4

STO S1

S1     1777.467 6.304 PSK2_SCHOTT

ASP

K   0.0

A -0.4049e-7

B -0.1216e-11

S2     0.0 170.946

S3     -211.8173 -96.2601 REFL

S4     -40.9571 -5.9437 PSK2_SCHOTT

S5     0.0 -1.7313

• More examples in New Lens Wizard, sample lenses (cassrc.len, maksutov.len, 
offner11, threemir, threemrc)

• For more info see Training Course Notes, Introduction, “Reflective Systems” 
(support.opticalres.com)
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Analyses

• Analysis > Diagnostics > Pupil Map
–OPD or intensity plot of wavefront at the exit pupil 

• Analysis > Diffraction > Point Spread Function
–Intensity plot of the PSF
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Analyses

• Settings button allows you to change options and re-run analysis

• Save/Load Settings… button allows you to save your options to apply in the 
future

*  Leave windows open so you can re-execute with the same options
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Analyses

• Use tear-away feature to compare before and after analysis

• Or save the text as a .txt file to see 
the name change in the navigation 
tree

- L-click the tab

- Drag to the left to make a 

copy

- Re-execute

Before After
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Analyses

• Can have multiple windows of same option

– Each window has its own settings

– Select desired window from System Navigator

New User Orientation
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Reports

• To save text or plotted output for your reports, use the File > Save Window As …

choice

• For plotted output, you can also use Copy & Paste (CTRL-C, CTRL-V)

• The LDM Spreadsheet and Review Spreadsheets can also be printed directly

–Verify the appearance with File > Print Preview



© 2016 Synopsys, Inc. 47 CODE V®

Use the Presentation/Report Template for clearer figures

PSF

MTF
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Click “Properties” to open full charting customization 

options
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Demo: Designing a Digital Camera Lens

Introduction to SpecBuilder and Automatic Design

New User Orientation
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Example: Digital Camera Lens

• Image sensor (baseline is Agilent FDCS-2020)
a. Type CMOS

b. Resolution 640 x 480 effective pixels

c. Pixel size 7.4 x 7.4 microns (correspond to maximum spatial frequency of ~68 lp/mm)

d. Sensitive area 4.74 x 3.55 mm (full diagonal 6-mm)

• Objective Lens
e. Focal length Fixed, 6.0 mm

f. ƒ/number Fixed aperture, ƒ/3.5

g. Spectral Band              656, 546, 435 nm (~ C, e, g) with 1,2,1 weighting

h. Semi-Field of View 26.5° (for 3-mm semi-diagonal and 6-mm EFL)

i. Geometric Distortion < 4%

j. Sharpness Radial & Tangential MTF

j. Vignetting Corner relative illumination > 60%

k. Transmission Lens alone, > 80%

l. Number of Elements  (1-3) made from common glasses or plastics

Low freq., 17 lp/mm > 50%

High freq., 68 lp/mm > 25%

CODE V® - Digital Camera Design Study
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Define the Specifications in SpecBuilder

CODE V® - Digital Camera Design Study
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Demo – Setup Lens

• File > New, click “Next”, choose patent lens, click “Next”, click “Filter…”,  select F/# 1-4, 
Semi-Field of View 20-33, Number of elements 1-3

• Choose or02248, click “Finish”
– This is a wider field, faster f/# than needed.

• Lens > System Data, select Pupil, chose Image F/# 3.5
• Select Wavelengths, change W2 weight to 2
• Select Fields, set type to object angle, define 4 fields: 0 11 19 26.5
• Select System Settings, change title to “CODE V Demo”
• Display > View Lens, note vignetting, 
• System Data, select Fields, click “Set Vignetting…”
• Display > View Lens, note vignetting, 
• Display > List lens data> First order data
• Edit > Scale, select Scale Effective Focal Length, surfaces 1 to 6, Scale Value = 6
• Re-run first order data, note change in EFL
• Re-draw lens
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Demo – Run Analysis

• Analysis > Diffraction > MTF, maximum freq. 68, increment freq. 17

• Analysis > Geometrical > Spot Diagram, select Aberration Scaling, Value 0.02

• Analysis > Diagnostics > Ray Aberration Curves, change Scale to 0.02
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Optimizing a Lens

• One of CODE V’s main strengths is the effectiveness of its optimization 
algorithms

–In particular, CODE V’s ability to control constraints exactly works better than any 
other commercial software

• CODE V optimization is easy to use, with very little input required by you in 
many cases

–This is mainly achieved through CODE V’s use of intelligent defaults

–However, the Automatic Design feature is also flexible and you can control many 
details of the optimization if you wish to
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Optimizing a Lens

• Add variables to any desired parameter

–Can select multiple cells by left-click and drag, or use CTRL+click

–Right-click on any highlighted cell, choose “Vary”
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Optimizing a Lens

• Select Optimization > Automatic Design

• Check General Constraints

• Define glass map

General constraints are limits placed 

on thicknesses for all surfaces. 

The glass map defines the boundary 

of glasses when varying the refractive 

index (Tools > Macro Manager > 

Sample Macros > Materials Info > 

vp_plot.seq)
0.005 0.010 0.015 0.020 0.025 0.030 0.035 0.040 0.045

1.50

1.55

1.60

1.65

1.70

1.75

1.80

1.85

1.90

1.95

2.00

1.45

1.40

BK7
LLF6

PSK3

LF7

F5
SK2 BaF52

BaF50

BaSF10
SSKN5

LaKN12

BaSF51

SF2

SF8

SF10

LaFN7

Fused silica

LaK8

LaSFN31
(881.410)

LaSFN18
(913.324)

SF58
(918.215)

SF11 (785.258)

SF6 (805.254)

SF57 (847.238)

LaF22A (782.372)

LaSFN30
(803.464)

LaSF3
(808.406)

SF4 (755.276)

FK5 (487.704)

LaF2

(744.447)

SK16

(620.603)

Default Boundary D Glass boundaries are denoted in CODE V

as A, B, C, ..., E.  These correspond to

the lines between user-entered or default

corner points 1 and 2, 2 and 3, 3 and 4, ...,

respectively.  The defaults shown (and their

Schott equivalents) correspond to the entry

GLA 487.704 620.603 744.447 755.276

Diagonal lines are lines of constant V number.

Default

Boundary A

PSK53A

LaK21

Default

Boundary B

Default Boundary C

V = 80 70 60 50 40 30

20

NF - NC

Nd
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Optimizing a Lens

• Define any specific constraints 
(EFL, distortion, surface 
thicknesses, ray trace data, etc.). 
These may override general 
constraints. 

• Note: exact constraints handled 
by linear algebra solutions 
(Lagrange multipliers) separate 
from error function, weighted 
constraints included in error 
function. 

Exact constraints

Weighted constraints

Unused constraints
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Optimizing a Lens

• Set output controls for drawing the lens at each cycle and printing text output. 

• If desired, change exiting conditions (max cycles, improvement factor, 
interactive mode). 

• Hit “OK” when finished, re-run any analyses.
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Demo - Optimization

• Vary curvatures for surfaces 1-6

• Vary thickness for surfaces 1-5 and image. Leave the paraxial image solve on surface 6

• Vary all glasses

• Open Automatic Design window, under Output Controls select Draw system at each cycle, 
under Specific Constraints add EFL = 6, click OK

• Rerun analyses and compare before and after results (open new window or use tear-away 
feature)

– Analysis > Diffraction > MTF, Maximum freq. 68, Increment freq. 17

– Analysis > Geometrical > Spot Diagram, select Aberration Scaling, Value 0.02

– Analysis > Diagnostics > Ray Aberration Curves, Scale 0.02

• Note that middle lens is too thin. Click settings button in Automatic Design window, under 
General Constraints change Minimum Center Thickness to 0.5, click OK

• Note thicker lenses. Rerun analyses and compare results.
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Demo - Optimization

• Commands
in cv_macro:extlen 'or02248'    ! load patent lens

fno 3.5                         ! pupil spec for f/#

WTW W2  2                       ! wavelength weight

yan 0 11 19 26.5                ! object field angles in Y

tit 'CODE V Demo'               ! set title

vie;go ! 2D plot

in cv_macro:setvig ! set vignetting

vie;go ! 2D layout

fir                             ! list 1st order data

SCA EFL  S1..I-1 6              ! scale lens to EFL of 6

fir                             ! list 1st order data

mtf; mfr 68; ifr 17; go         ! run MTF, max freq. 68, increment 17

spo; ssi .02; go                ! run spot diagram, plot scale .02

rim; ssi .02; go                ! run ray aberration curves, plot scale .02

ccy s1..6 0                     ! vary curvatures

thc s1..5 0                     ! vary thicknesses

thc si 0

gc1 s1 0                        ! vary glasses

gc1 s3 0

gc1 s5 0
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Demo - Optimization

• Commands (cont’d)

aut;dra;efl=6;go                ! optimize, draw the system at each cycle

mtf; mfr 68; ifr 17; go         ! rerun analysis as before

spo; ssi .02; go

rim; ssi .02; go

aut;dra;efl=6;mnt .5;go         ! optimize, set min thickness of .5

mtf; mfr 68; ifr 17; go         ! rerun analysis as before

spo; ssi .02; go

rim; ssi .02; go
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CODE V Help

• CODE V reference manual (PDF) has the most info

e.g. Search on “database items” 

provides links to syntax for various 

database info (curvatures, 

thicknesses, pupil size… any 

CODE V info)
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Welcome to CODE V!

New User Orientation


